• Welcome to Photography Forum. Our photography community!

    Photography-forum is dedicated to those who have passion, desire and love of photography and want to improve their photographic technique. It doesn't matter what you photograph, landscapes, weddings, portraits or your photographic experience, it's about learning and loving what we do. Photography!

    If you want learn and expand your photography skills then there is one place to do it Photography Forum !!!

    You are viewing photography-forum as a guest which gives you limited access to view most forums and enjoy other features. By joining our free community you will be able to post photographs for critique, join in the monthly photography competitions, respond to polls, upload content and enjoy many other special features. Registration is fast, simple and absolutely free so please join Photography Forum.

    If you have any problems please contact us.

    The Photography-Forum Team
  • PLEASE SEE RULES BEFORE POSTING LINKS
    Click here to see Forum Rules

Miranda MS-3 Mystery

zhuologist

Member
Joined
Aug 24, 2021
Messages
7
Photography Experience
Advanced
Photo Editing Experience
Beginner
Edit my images ?
Yes (recommended)
I've just acquired a Miranda MS-3 with Miranda 28-70mm zoom lens. I did not particularly want it but it came as a job lot with a Zeiss Werra Mat, which I did want. However, now I've got it I've taken quite a shine to it. It appears to be in perfect condition but for a fault(?) which has me baffled. When I press the shutter button the mirror flips up as normal, but does not return unless I remove the lens. Without the lens in place it seems to work perfectly. I notice that at the top of the lens opening just below the pentaprism there are 3 electrical contacts but no corresponding contacts on the rear of the lens. Is this relevant? I have fitted new batteries and tried the reset button. Any suggestions gratefully received.
 

Classicbiker

Old Hand
Premium Member
Joined
Jun 10, 2021
Messages
573
Photography Experience
Advanced
Photo Editing Experience
Intermediate
Edit my images ?
Yes (recommended)
Does it have a mirror lockup switch?
 

zhuologist

Member
Joined
Aug 24, 2021
Messages
7
Photography Experience
Advanced
Photo Editing Experience
Beginner
Edit my images ?
Yes (recommended)
Does it have a mirror lockup switch?
Hi Classicbiker,
No, there does not appear to be a lockup switch. The mirror works normally without the lens, which is baffling. I've read through the online manual without success.
 

Classicbiker

Old Hand
Premium Member
Joined
Jun 10, 2021
Messages
573
Photography Experience
Advanced
Photo Editing Experience
Intermediate
Edit my images ?
Yes (recommended)
Hi Classicbiker,
No, there does not appear to be a lockup switch. The mirror works normally without the lens, which is baffling. I've read through the online manual without success.
It could be a fault on the lens coupling or a faulty lens. Have you got another lens to try?
 

zhuologist

Member
Joined
Aug 24, 2021
Messages
7
Photography Experience
Advanced
Photo Editing Experience
Beginner
Edit my images ?
Yes (recommended)
It could be a fault on the lens coupling or a faulty lens. Have you got another lens to try?
Sadly I have no other lenses that will fit this. I'm visiting a friend soon who may well have one. Meantime, I'll examine the lens more closely for a possible fault. Thanks for your suggestion.
 

BrianS

Well-Known Member
Joined
Jan 20, 2020
Messages
173
Photography Experience
Advanced
Photo Editing Experience
Advanced
Edit my images ?
No

Link to the Manual. The electrical contacts are for the AF lens available for this camera. Other K mount lenses should work just fine.

Either the lens/camera linkage is hanging up, or the camera needs a good cleaning and lube. If you can borrow a second lens, that would give a way to test that the current lens is not the problem.
 

zhuologist

Member
Joined
Aug 24, 2021
Messages
7
Photography Experience
Advanced
Photo Editing Experience
Beginner
Edit my images ?
Yes (recommended)

Link to the Manual. The electrical contacts are for the AF lens available for this camera. Other K mount lenses should work just fine.

Either the lens/camera linkage is hanging up, or the camera needs a good cleaning and lube. If you can borrow a second lens, that would give a way to test that the current lens is not the problem.
Hi Brian,
Many thanks for your suggestions. I think I can lay my hands on another K-mount lens in due course. I took the zoom lens apart then reassembled it, after a fashion, but could find no fault with it. I'm baffled as to why the camera works perfectly without a lens - will study the online manual in more detail to see if I've overlooked anything.
Regards, Nick B.
 
Top